HDU 2412 Party at Hali-Bula

ProblemDescription

Dear Contestant,

I'm going to have a party at my villa at Hali-Bula to celebrate my retirementfrom BCM. I wish I could invite all my co-workers, but imagine how an employeecan enjoy a party when he finds his boss among the guests! So, I decide not toinvite both an employee and his/her boss. The organizational hierarchy at BCMis such that nobody has more than one boss, and there is one and only oneemployee with no boss at all (the Big Boss)! Can I ask you to please write aprogram to determine the maximum number of guests so that no employee isinvited when his/her boss is invited too? I've attached the list of employeesand the organizational hierarchy of BCM.

Best,
--Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list ofpeople is uniquely determined if I choose to invite the maximum number ofguests with that condition.

 

 

Input

The input consistsof multiple test cases. Each test case is started with a line containing aninteger n (1 ≤ n ≤ 200), the number of BCM employees. The next line containsthe name of the Big Boss only. Each of the following n-1 lines contains thename of an employee together with the name of his/her boss. All names arestrings of at least one and at most 100 letters and are separated by blanks.The last line of each test case contains a single 0.

 

 

Output

For each testcase, write a single line containing a number indicating the maximum number ofguests that can be invited according to the required condition, and a word Yesor No, depending on whether the list of guests is unique in that case.

 

 

Sample Input

6

Jason

Jack Jason

Joe Jack

Jill Jason

John Jack

Jim Jill

2

Ming

Cho Ming

0

 

 

Sample Output

4 Yes

1 No

题目大意:有n个人,首先输入根节点的名字,接着输入下属——上司关系。现在要求选一些人出来,保证这些人中没有直接相连的关系,即直接上司不在人中,要求能选人数的最大值。

这道题同hdu1520,就不过多赘述了。http://blog.csdn.net/catalyst1314/article/details/9663497

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<vector>
#include<algorithm>
using namespace std;

char name[210][110];
int n ,top;
char ch[110];
vector<int> v[210];
int dp[210][2] ,dup[210][2];

void solve(int x)
{
    dup[x][0] = dup[x][1] = 1;
    dp[x][1] = 1;
    dp[x][0] = 0;
    for(int i = 0;i < v[x].size();i++)
    {
        solve(v[x][i]);
        if((dp[v[x][i]][0] > dp[v[x][i]][1] && dup[v[x][i]][0] == 0) || (dp[v[x][i]][0] < dp[v[x][i]][1] && dup[v[x][i]][1] == 0)||(dp[v[x][i]][0] == dp[v[x][i]][1]))
        {
               dup[x][0] = 0;
        }
        dp[x][0] += max(dp[v[x][i]][0],dp[v[x][i]][1]);
        if(dup[v[x][i]][0]==0)
        {
                dup[x][1] = 0;
        }
        dp[x][1] += dp[v[x][i]][0];
    }
}

int main()
{
    int index ,index1;
    while(scanf("%d",&n),n)
    {
        top = 0;
        scanf("%s",name[0]);
        top++;
        for(int i = 1;i < n;i++)
        {
            scanf("%s",ch);
            index = -1;
            for(int j = 0;j<top;j++)
            {
                if(strcmp(ch,name[j])==0)
                {
                    index = j;
                    break;
                }
            }
            if(index==-1)
            {
                strcpy(name[top],ch);
                index = top;
                top++;
            }
            scanf("%s",ch);
            index1 = -1;
            for(int j = 0;j<top;j++)
            {
                if(strcmp(ch,name[j])==0)
                {
                    index1 = j;
                    break;
                }
            }
            if(index1==-1)
            {
                strcpy(name[top],ch);
                index1 = top;
                top++;
            }
            v[index1].push_back(index);
        }
        solve(0);
        if(dp[0][0]==dp[0][1])
        {
            printf("%d No\n",dp[0][0]);
        }
        else if(dp[0][0] > dp[0][1])
        {
            printf("%d ",dp[0][0]);
            if(!dup[0][0])
            {
                printf("No\n");
            }
            else
            {
                printf("Yes\n");
            }
        }
        else
        {
            printf("%d ",dp[0][1]);
            if(!dup[0][1])
            {
                printf("No\n");
            }
            else
            {
                printf("Yes\n");
            }
        }
        for(int i = 0;i < top;i++)
        {
            v[i].clear();
        }
    }
    return 0;
}


 

你可能感兴趣的:(HDU 2412 Party at Hali-Bula)