BestCoder Round #80A

Lucky

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 507    Accepted Submission(s): 298



判断0和1是否存在;
Problem Description
     Chaos August likes to study the lucky numbers.

     For a set of numbers S,we set the minimum non-negative integer,which can't be gotten by adding the number in S,as the lucky number.Of course,each number can be used many times.

     Now, given a set of number S, you should answer whether S has a lucky number."NO" should be outputted only when it does have a lucky number.Otherwise,output "YES".
 

Input
     The first line is a number T,which is case number.

     In each case,the first line is a number n,which is the size of the number set.

     Next are n numbers,means the number in the number set.

    1n105,1T10,0ai109 .
 

Output
     Output“YES”or “NO”to every query.
 

Sample Input
   
   
   
   
1 1 2
 

Sample Output
   
   
   
   
NO
 

Source
BestCoder Round #80
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5669  5668  5667  5664  5663

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
using namespace std;

int main()
{
    int t,n;
    cin>>t;
    int x;
    while(t--)
    {
        int flag1=0,flag0=0;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>x;
            if(x==1)
                flag1=1;
            else if(x==0)
                flag0=1;
        }
        if(flag1&&flag0)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


 

你可能感兴趣的:(BestCoder Round #80A)