HDU2602

Q - Bone Collector

Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

这是最基础的背包问题,特点是:每种物品仅有一件,可以选择放或不放。
用子问题定义状态:即f 【i】【v】表示前i件物品恰放入一个容量为v的背包可以获得的最大价值。则其状态转移方程便是:

f[i][v]=max{f[i-1][v],f[i-1][v-c[i]]+w[i]}

这个方程非常重要,基本上所有跟背包相关的问题的方程都是由它衍生出来的。所以有必要将它详细解释一下:
“将前i件物品放入容量为v的背包中”这个子问题,
若只考虑第i件物品的策略(放或不放),那么就可以转化为一个只牵扯前i-1件物品的问题。
如果不放第i件物品,那么问题就转化为“前i-1件物品放入容量为v的背包中”,价值为f[i-1][v];
如果放第i件物品,那么问题就转化为“前i-1件物品放入剩下的容量为v-c[i]的背包中”,此时能获得的最大价值就是f[i-1][v-c[i]]再加上通过放入第i件物品获得的价值w[i]。

#include "iostream"
#include "cstdio"
#include "cstring"
#include "string.h"
#include "algorithm"

using namespace std;

int main()
{
    int tcase;
    while(scanf("%d",&tcase)!=EOF)
    {
        while(tcase--)
        {
            int num,volume;
            scanf("%d%d",&num,&volume);
            int value[1005];
            int vol[1005];
            for(int i=1;i<=num;i++)
                scanf("%d",&value[i]);
            for(int i=1;i<=num;i++)
                scanf("%d",&vol[i]);
            int dp[1005][1005];   //dp[i][j] 放到第i个,j为剩余容量
            memset(dp,0,sizeof(dp));

            for(int i=1;i<=num;i++)
            {
                for(int j=0;j<=volume;j++)
                {
                    if(vol[i]<=j)
                        dp[i][j]=max(dp[i-1][j],dp[i-1][j-vol[i]]+value[i]);
                    else
                        dp[i][j]=dp[i-1][j];
                }
            }
            printf("%d\n",dp[num][volume]);

        }
    }
}

你可能感兴趣的:(dp,背包问题)