素数筛

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

一段区间内求素数。



#include<iostream>

using namespace std;
long long prime[46500], prime1[1000010], pcount, p1count, in[46500], in1[1000010];

void getsprime()
{
	for (int i =2; i < 46500; ++i)
	{
		in[i] = 1;
	}
	for (int i = 2; i*i <= 46500; ++i)
	{
		if (in[i])
		{
			for (int j = 2 * i; j < 46500; j += i)
			{
				in[j] = 0;
			}
		}
	}
	pcount = 0;
	for (int i = 2; i < 46500; ++i)
	{
		if (in[i])
			prime[pcount++] = i;
	}
}
void getlprime(__int64 L, __int64 U)
{
	if (U < 46500)
	{
		p1count = 0;
		for (__int64 i = L; i <= U; ++i)
		{
			if (in[i])
				prime1[p1count++] = i;
		}
	}
	else
	{
		for (int i = 0; i <= U - L; ++i)
			in1[i] = 1;
		for (__int64 i = 0; i <= pcount && prime[i] * prime[i] <= U; ++i)
		{
			__int64 k = L / prime[i];
			if (k*prime[i] < L)
			{
				k++;
			}
			if (k <= 1)
				k++;
			while (k*prime[i] <= U)
			{
				in1[k*prime[i] - L] = 0;
				k++;
			}
		}
		p1count = 0;
		for (__int64 i = 0; i <= U-L; ++i)<span style="white-space:pre">	</span>//注意这里i不是从0到最后,而是有限制的
		{
			if (in1[i])
				prime1[p1count++] = i+L;
		}
	}
}


int main()
{
	//void getsprime();
	getsprime();//构建1到46500(即sqrt(2147483647))之间的素数表 
	long long L, U;
	while (cin >> L >> U)
	{
		getlprime(L, U);//构造给定区间的素数表 
		if (p1count<2)//假如有筛出的素数中,素数的个数小于2个,那么就一定不可能存在相邻的两个素数 
		{
			cout << "There are no adjacent primes." << endl;
			continue;
		}
		else
		{
			long long min = 2147483647, max = -1;
			long long distant, xmin, ymin, xmax, ymax;
			for (long i = 0; i<p1count - 1; ++i)
			{
				distant = prime1[i + 1] - prime1[i];
				if (distant<min)//找最小距离的位置 
				{
					min = distant;
					xmin = i;
					ymin = i + 1;
				}
				if (distant>max)//找最大距离的位置 
				{
					max = distant;
					xmax = i;
					ymax = i + 1;
				}
			}
			cout << prime1[xmin] << ',' << prime1[ymin] << " are closest, " << prime1[xmax] << ',' << prime1[ymax] << " are most distant." << endl;
		}
	}
	return 0;
}


你可能感兴趣的:(C++,算法,ACM)