POJ 3069Saruman's Army

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1
Sample Output

2

4


这一题样的是贪心算法,具体的思路是这样的:找到一个未标记的点a,往右找到离a最远的在R的距离之内的点b,将b坐上标记,然后在标记点b往右在距离R之内的点相当于被标记;


AC代码:


# include <cstdio>
# include <cstring>
# include <algorithm>
using namespace std;
int s[1010];
int flage[1010];
int main(){
	int n, r, ans, cur, i, j, k;
	while(scanf("%d%d", &r, &n)!=EOF){
		 if(r==-1&&n==-1){
	 		break;
		 }
		 ans=0;
		 for(i=1; i<=n; i++){
		 	scanf("%d", &s[i]);
		 }
		 sort(s+1, s+1+n);
		 memset(flage, 0, sizeof(flage));
		 for(i=1; i<=n; i++){
			if(!flage[i]){
				ans++; 
				cur=i;
				flage[i]=1;
				for(j=i+1; j<=n; j++){
					if(s[i]+r>=s[j]){
						cur=j;
						flage[j]=1;
					}
					else{
						break;
					}
				}
				for(j=cur+1; j<=n; j++){
					if(s[cur]+r>=s[j]){
						flage[j]=1;
					}
				}
			}
		 }
		 printf("%d\n", ans);
	}
	return 0;
}


你可能感兴趣的:(算法,ACM,poj,贪心)