Hduoj1162【最小生成树】

/*Eddy's picture 
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 0   Accepted Submission(s) : 0
Font: Times New Roman | Verdana | Georgia 
Font Size: ← →
Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, 
and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested 
in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem
 for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line,
 causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers 
indicating the (x,y) coordinates of the point. 

Input contains multiple test cases. Process to the end of file.

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 

Sample Input
3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output
3.41

Author
eddy */
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
struct point
{
	float x, y ;
} p[110];
struct road
{
	int i, j;
	float dis;
}r[5010];
int  a[110];
int find(int x)
{
	if(x != a[x])
	{
		a[x] = find(a[x]);
	}
	return a[x];
} 
int merge(int i, int j)
{
	i = find(i);
	j = find(j);
	if(i != j)
	{
		a[i] = j;
		return 1;
	}
	return 0;
}
int cmp(const void*a, const void*b)
{
	return (*(struct road*)a).dis > (*(struct road*)b).dis?1:-1;//第一次提交这里偷懒了问号及后面的没写,原来是不行的,float排序必须要那么写
}
int main()
{
	int n;
	while(scanf("%d", &n) != EOF)
	{
		for(int i = 1; i <= n; i++)
		{
			scanf("%f%f", &p[i].x, &p[i].y);
		}
		int k = 0;
		for(int i = 1; i <= n; i++)
		{
			for(int j = i+1; j <= n; j++)
			{
				r[++k].i = i;
				r[k].j = j;
				r[k].dis = sqrt((p[i].x - p[j].x) * (p[i].x - p[j].x) + (p[i].y - p[j].y)*(p[i].y - p[j].y));
			}
		}
		qsort(r+1, k, sizeof(r[0]), cmp);
		for(int i = 1; i <= n; i++)
		a[i] = i;
		float len = 0;
		for(int i = 1; i <= k; i++)
		{
			if(merge(r[i].i, r[i].j))
			len += r[i].dis;
		}
		printf("%.2f\n", len);
	}	
	return 0;
}

题意:给出n个点的坐标,求怎样将这n个点连线长度最短,只要任意两点可以互相连通即可。

思路:先记录点的坐标并标号,接着计算两两之间的距离,接着就是标准的模板代码了。

你可能感兴趣的:(c)