UVA674Coin Change母函数模板题目

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make
changes with these coins for a given amount of money.
For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent
coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins.
So there are four ways of making changes for 11 cents with the above coins. Note that we count that
there is one way of making change for zero cent.
Write a program to find the total number of different ways of making changes for any amount of
money in cents. Your program should be able to handle up to 7489 cents.
Input
The input file contains any number of lines, each one consisting of a number for the amount of money
in cents.
Output
For each input line, output a line containing the number of different ways of making changes with the
above 5 types of coins.
Sample Input
11
26
Sample Output
4
13
题意分析,对于给定的一个数,问用1,2,10,25,50,能够表示多少次。
母函数模板
母函数详细解析http://blog.csdn.net/wuxiushu/article/details/51211305
<pre name="code" class="cpp">#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>

using namespace std;

long long c1[10010],c2[10010];
int num[10] = {1,5,10,25,50};

void Init()
{
    for(int i = 0; i <= 7500; i ++)
    {
        c1[i] = 1;
        c2[i] = 0;
    }
    for(int i = 1; i <= 4; i ++)
    {
        for(int j = 0; j <= 7500; j ++)
            for(int k = 0; k + j <= 7500; k += num[i])
                c2[j+k] += c1[j];
        for(int i = 0; i <= 7500; i ++)
            c1[i] = c2[i];
        memset(c2,0,sizeof(c2));
    }
}

int main()
{
    int n;
    Init();
    while(~scanf("%d",&n))
    {
        cout << c1[n] << endl;
    }
    return 0;
}



DP解法

#include <cstdio>
const int MAXN = 8000;
int n, coin[5] = {1, 5, 10, 25, 50};
long long dp[MAXN] = {1};

int main()
{
    for (int i = 0; i < 5; i++)
        for (int j = 0; j < MAXN - 100; j++)
            dp[j + coin[i]] += dp[j];

    while (scanf("%d", &n) != EOF)
        printf("%lld\n", dp[n]);
    return 0;
}

你可能感兴趣的:(dp,ACM,uva)