深搜 hdu —— 1010

上加礼#——买六个月送域名代金券!

Tempter of the Bone

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
       
       
       
       
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
       
       
       
       
NO YES

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1010

用深搜+剪枝

剪枝1:超界返回

剪枝2:判断 剩余时间=总时间-已用时间-此时距门的距离  是否为负,或是否为奇数,则返回

剪枝3:刚好到达则返回


#include<stdio.h>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;
int n,m,kk,p;
int sx,sy,ex,ey;
char map[10][10];
const int c[4][2]={1,0,-1,0,0,1,0,-1};
void dfs(int x,int y,int num){
	int dd,kx,ky;
	if(x<=0 || y<=0 || x>n || y>m)	return ;
	if(x==ex && y==ey && kk==num){
		p=1;
		return ;
	}
	
	dd=kk-num-abs(x-ex)-abs(y-ey);
	if(dd<0 || dd%2)	return ;
	for(int i=0;i<4;i++){
		kx=x+c[i][0];
		ky=y+c[i][1];
		if(map[kx][ky]!='X'){
			map[kx][ky]='X';
			dfs(kx,ky,num+1);
			map[kx][ky]='.';
			if(p)	return ;
		}
	}
	return ;
}

int main()
{
	while(~scanf("%d%d%d",&n,&m,&kk)){
		if(n==0 && m==0 && kk==0)	break;
		for(int i=1;i<=n;i++){
			for(int j=1;j<=m;j++){
				cin>>map[i][j];
				if(map[i][j]=='S'){
					sx=i;
					sy=j;
				}
				if(map[i][j]=='D'){
					ex=i;
					ey=j;
				}
			}
		}
		p=0;
		map[sx][sy]='X';
		dfs(sx,sy,0);
		if(p)	cout<<"YES"<<endl;
		else	cout<<"NO"<<endl;
	}
	return 0;
}


你可能感兴趣的:(搜索)