Conversions(水)

Conversions

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1054    Accepted Submission(s): 618


Problem Description
Conversion between the metric and English measurement systems is relatively simple. Often, it involves either multiplying or dividing by a constant. You must write a program that converts between the following units:

 

Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of a single line of input containing a floating point (double precision) number, a space and the unit specification for the measurement to be converted. The unit specification is one of kg, lb, l, or g referring to kilograms, pounds, liters and gallons respectively.
 

Output
For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the appropriately converted value rounded to 4 decimal places, a space and the unit specification for the converted value.

 

Sample Input
   
   
   
   
5 1 kg 2 l 7 lb 3.5 g 0 l
 

Sample Output
   
   
   
   
1 2.2046 lb 2 0.5284 g 3 3.1752 kg 4 13.2489 l 5 0.0000 g
 

Source
2008 “Shun Yu Cup” Zhejiang Collegiate Programming Contest - Warm Up(1)
 

Recommend
linle
 
#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#define LL long long
#define maxi 2147483647
#define maxl 9223372036854775807
#define dg cout << "Here!" << endl;
using namespace std;

int main()
{
    int n, t = 1;
    double a;
    string s;
    cin >> n;
    while(n--)
    {
        cin >> a >> s;
        if(s == "kg")
           printf("%d %.4lf lb\n", t++, a * 2.2046);
        else if(s == "lb")
            printf("%d %.4lf kg\n", t++, a * 0.4536);
        else if(s == "l")
            printf("%d %.4lf g\n", t++, a * 0.2642);
        else if(s == "g")
            printf("%d %.4lf l\n", t++, a * 3.7854);
    }
    return 0;
}


你可能感兴趣的:(String,Integer,input,each,dataset,output)