HDOJ 5240 Exam (贪心)

Exam

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1056    Accepted Submission(s): 525


Problem Description
As this term is going to end, DRD needs to prepare for his final exams.

DRD has n exams. They are all hard, but their difficulties are different. DRD will spend at least ri hours on the i -th course before its exam starts, or he will fail it. The i -th course's exam will take place ei hours later from now, and it will last for li hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time.

So he wonder whether he can pass all of his courses.

No two exams will collide.
 

Input
First line: an positive integer T20 indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer n105 , and n lines follow. In each of these lines, there are 3 integers ri,ei,li , where 0ri,ei,li109 .

 

Output
For each test case: output ''Case #x: ans'' (without quotes), where x is the number of test cases, and ans is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes).

 

Sample Input
   
   
   
   
2 3 3 2 2 5 100 2 7 1000 2 3 3 10 2 5 100 2 7 1000 2
 

Sample Output
   
   
   
   
Case #1: NO Case #2: YES
 
题意:N个科目以及每个科目需要复习的时间、每个科目开始考试的时间、每个科目考试所持续的时间,
判断能不能通过所有科目的考试(在考试的时候不能做任何事情)。可以用复习完上一门科目的剩余时间来复习下一门科目。

思路:按考试时间排序,模拟复习 + 考试  即可。



ac代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<stack>
#include<iostream>
#include<algorithm>
#define fab(a) (a)>0?(a):(-a)
#define MAXN 100010
#define INF 0xfffffff
using namespace std;
struct s
{
	int r,e,l;
}a[MAXN];
bool cmp(s aa,s bb)
{
	if(aa.e!=bb.e)
	return aa.e<bb.e;
	return aa.r<bb.r;
}
int main()
{
	int t;
	int cas=0;
	int i,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
		scanf("%d%d%d",&a[i].r,&a[i].e,&a[i].l);
		sort(a,a+n,cmp);
//		for(i=0;i<n;i++)
//		printf("%d %d %d\n",a[i].r,a[i].e,a[i].l);
		int bz=0;
		int num=0;
		for(i=0;i<n;i++)
		{
			if(num>a[i].e||num+a[i].r>a[i].e)
			{
				bz=1;
				break;
			}
			else
			{
				num=a[i].l+a[i].e;
			}
		}
		printf("Case #%d: ",++cas);
		printf(bz?"NO\n":"YES\n");
	}
	return 0;
}


你可能感兴趣的:(HDOJ 5240 Exam (贪心))