POJ 3734 —— 矩阵快速幂 + DP

Blocks
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3716   Accepted: 1645

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6

Source

PKU Campus 2009 (POJ Monthly Contest – 2009.05.17), Simon

题意是给你一列N个方块,要用红蓝绿黄四种颜色给方块染色,让你输出染成红色和染成绿色同时为偶数的染色方案数,结果对10007取模

思路是设a[i]为红绿都是偶数,b[i]为红绿有一个为偶数,c[i]为都不是偶数。我们有a[i + 1] = 2 * a[i] + b[i];b[i + 1] = 2 * a[i] + 2 * b[i] + 2 * c[i] ; c[i + 1] = b[i] + 2 * c[i];然后矩阵快速幂即可。

#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
#include <stack>
#include <cctype>
#include <vector>
#include <queue>
#include <set>
#include <utility>
#include <cassert>
using namespace std;
///#define Online_Judge
#define outstars cout << "***********************" << endl;
#define clr(a,b) memset(a,b,sizeof(a))
#define lson l , mid  , rt << 1
#define rson mid + 1 , r , rt << 1 | 1
#define mk make_pair
#define FOR(i , x , n) for(int i = (x) ; i < (n) ; i++)
#define FORR(i , x , n) for(int i = (x) ; i <= (n) ; i++)
#define REP(i , x , n) for(int i = (x) ; i > (n) ; i--)
#define REPP(i ,x , n) for(int i = (x) ; i >= (n) ; i--)
const int MAXN = 1000000000 + 5;
const int MAXS = 10000 + 50;
const int sigma_size = 26;
const long long LLMAX = 0x7fffffffffffffffLL;
const long long LLMIN = 0x8000000000000000LL;
const int INF = 0x7fffffff;
const int IMIN = 0x80000000;
const int inf = 1 << 30;
#define eps 1e-8
const long long MOD = 1000000000 + 7;
const int mod = 10007;
typedef long long LL;
const double PI = acos(-1.0);
typedef double D;
typedef pair<int , int> pii;
typedef vector<int> vec;
typedef vector<vec> mat;


#define Bug(s) cout << "s = " << s << endl;
///#pragma comment(linker, "/STACK:102400000,102400000")
int n;

mat mul(mat & A , mat & B)
{
    mat C(A.size() , vec(B[0].size()));
    for(int i = 0 ; i < A.size() ; i++)
    {
        for(int k = 0 ; k < B.size() ; k++)
        {
            for(int j = 0  ; j < B[0].size() ; j++)
            {
                C[i][j] = (C[i][j] + A[i][k] * B[k][j]) % mod;
            }
        }
    }
    return C;
}
mat pow(mat A , LL n)
{
    mat B(A.size() , vec(A.size()));
    for(int i = 0 ; i < A.size() ; i++)B[i][i] = 1;
    while(n > 0)
    {
        if(n & 1)B = mul(B , A);
        A = mul(A , A);
        n >>= 1;
    }
    return B;
}
void solve()
{
    mat A (3 , vec(3));
    A[0][0] = 2 ; A[0][1] = 1; A[0][2] = 0;
    A[1][0] = 2 ; A[1][1] = 2; A[1][2] = 2;
    A[2][0] = 0 ; A[2][1] = 1; A[2][2] = 2;
    A = pow(A , n);
    printf("%d\n" , A[0][0]);
}
int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        scanf("%d" , &n);
        solve();
    }
    return 0;
}


你可能感兴趣的:(dp,ACM,矩阵快速幂)