HDOJ 2199 Can you solve this equation?(二分)

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12784    Accepted Submission(s): 5707


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
   
   
   
   
2 100 -4
 

Sample Output
   
   
   
   
1.6152 No solution!
 

赤裸裸的二分:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;
double fun(double x)
{
	return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{
	int t;
	double y;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf",&y);
		double low=0,high=100;
		double mid;
		if(y<fun(0)||y>fun(100))
		{
		   printf("No solution!\n");
		   continue;
	    }
		while(high-low>1e-10)
		{
			mid=(high+low)/2.0;
			if(fabs(fun(mid)-y)<1e-10)//精度
			break;
			else if(fun(mid)>y)
			{
				high=mid;
			}
			else
			low=mid;
		}
		printf("%.4lf\n",mid);
	}
	return 0;
}


你可能感兴趣的:(HDOJ 2199 Can you solve this equation?(二分))