第三周项目二 本月有几天

/*copyright(c)2016.烟台大学计算机学院
* All rights reserved,
* 文件名称:my dream,Cpp
* 作者:舒文超
* 完成日期:2016年3月8日
* 版本号:vc++6.0
*
* 问题描述:
           输入年份和月份,输出本月有多少天。合理选择分支语句完成设计任务。
  样例输入:
           2004 2;
  样例输出:
           本月29天
*/
#include<iostream>
using namespace std;
int main()
{
    int a[13]= {0,31,28,31,30,31,30,31,31,30,31,30,31};
    int year,month;
    cin>>year>>month;
    if(year%4==0&&year%100!=0 || year%400==0)
    {
        a[2]=29;
        cout<<a[month];
    }
    else
        cout<<a[month];
    return 0;
}

你可能感兴趣的:(第三周项目二 本月有几天)