Fractal
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8604 Accepted: 4081
Description
A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales.
A box fractal is defined as below :
•A box fractal of degree 1 is simply
X
• A box fractal of degree 2 is
X X
X
X X
•If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following
B(n - 1) B(n - 1)
B(n - 1)
B(n - 1) B(n - 1)
Your task is to draw a box fractal of degree n.
Input
The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.
Output
For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.
Sample Input
1
2
3
4
-1
Sample Output
X
-
X X
X
X X
-
X X X X
X X
X X X X
X X
X
X X
X X X X
X X
X X X X
-
X X X X X X X X
X X X X
X X X X X X X X
X X X X
X X
X X X X
X X X X X X X X
X X X X
X X X X X X X X
X X X X
X X
X X X X
X X
X
X X
X X X X
X X
X X X X
X X X X X X X X
X X X X
X X X X X X X X
X X X X
X X
X X X X
X X X X X X X X
X X X X
X X X X X X X X
-
Source
代码:
#include<iostream>
#include<string.h>
#include<map>
#include<cmath>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
using namespace std;
char a[800][800];
void dfs(int n,int x,int y)
{
if(n==1)
{
a[x][y]='X';
return ;
}
else
{
int size=pow(3,n-2);
dfs(n-1,x,y);
dfs(n-1,x+size+size,y);
dfs(n-1,x+size,y+size);
dfs(n-1,x,y+size+size);
dfs(n-1,x+size+size,y+size+size);
}
}
int main()
{
int t;
while(cin>>t)
{
if(t<=0)
break;
int size=pow(3,t-1);
for(int i=0;i<size;i++)
{
for(int j=0;j<size;j++)
{
a[i][j]=' ';
}
}
dfs(t,0,0);
for(int i=0;i<size;i++)
{
a[i][size]='\0';
}
for(int i=0;i<size;i++)
{
puts(a[i]);
}
printf("-\n");
}
}