hdu 1796 How many integers can you find(容斥原理)

How many integers can you find



Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
   
   
   
   
12 2 2 3
 

Sample Output
   
   
   
   
7
 

Author
wangye
 

Source
2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(4)


简单的容斥原理
答案等于整除1个数的和-整除2个数的和+整除3个数的和……
#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#define LL long long
using namespace std;
int n,m,cnt;
LL ans,a[30];
long long gcd(LL a,LL b)
{
    return b==0?a:gcd(b,a%b);
}
void DFS(int cur,LL lcm,int id)
{
    lcm=a[cur]/gcd(a[cur],lcm)*lcm;
    if(id&1)
        ans+=(n-1)/lcm;
    else
        ans-=(n-1)/lcm;
    for(int i=cur+1;i<cnt;i++)
        DFS(i,lcm,id+1);
}
int main()
{
    while(~scanf("%d%d",&n,&m)){
        cnt=0;
        int x;
        while(m--)
        {
            scanf("%d",&x);
            if(x!=0)   
                a[cnt++]=x;
        }
        ans=0;
        for(int i=0;i<cnt;i++)
            DFS(i,a[i],1);
        cout<<ans<<endl;
    }
    return 0;
}

你可能感兴趣的:(hdu 1796 How many integers can you find(容斥原理))