ACM 搜索 hdu1010 Tempter of the Bone

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
   
   
   
   
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
   
   
   
   
NO YES

 


搜索问题,题意是非常简单的,很常规的搜索。但是数据很大,需要进行剪枝处理,否则会超时


奇偶减枝(百科)

现假设起点为(sx,sy),终点为(ex,ey),给定t步恰好走到终点,
s
       
|
       
|
       
|
       
+
e
如图所示(“|”竖走,“—”横走,“+”转弯),易证abs(ex-sx)+abs(ey-sy)为此问题类中任意情况下,起点到终点的最短步数,记做step,此处step1=8;
s
 
 
+
 
|
+
     
|
       
+
e
如图,为一般情况下非 最短路径的任意走法举例,step2=14;
step2-step1=6,偏移路径为6,偶数(易证);

结论

编辑
推广之,若 t-[abs(ex-sx)+abs(ey-sy)] 结果为非偶数(奇数),则无法在t步恰好到达;
返回,false;
反之亦反。




#include <stdio.h>
#include <string.h>
#include <math.h>


int n,m,t;
char map[10][10];
int flag;
int di,dj,wall;
int to[4][2] = {{0,-1},{0,1},{-1,0},{1,0}};


void dfs(int si,int sj,int cnt)//深搜
{
    int i,tem;
    if(si>n || sj>m || si<=0 || sj <= 0)//出界
        return ;
    if(cnt == t && si == di && sj == dj)//到达终点
        flag = 1;
    if(flag)
        return ;
    int s1 = si-di;
    int s2 = sj-dj;
    if(s1<0)
        s1=-s1;
    if(s2<0)
        s2=-s2;
    tem = t-cnt - s1 - s2;
    if(tem<0 || tem&1)//看剩下的时间能能否到达终点,tem&1则是判断其是否偶数,根据LCY的奇偶性剪枝可得tem必须是偶数,是奇数则不行
        return;
    for(i = 0; i<4; i++)
    {
        if(map[si+to[i][0]][sj+to[i][1]]!='X')
        {
            map[si+to[i][0]][sj+to[i][1]]='X';//走过的地方变为墙
            dfs(si+to[i][0],sj+to[i][1],cnt+1);
            map[si+to[i][0]][sj+to[i][1]]='.';//迷宫还原,以便下次广搜
        }
    }
    return ;
}


int main()
{
    int i,j,si,sj;
    while(~scanf("%d%d%d%*c",&n,&m,&t))
    {
        if(!n && !m && !t)
            break;
        wall = 0;
        for(i = 1; i<=n; i++)
        {
            for(j = 1; j<=m; j++)
            {
                scanf("%c",&map[i][j]);
                if(map[i][j] == 'S')
                {
                    si = i;
                    sj = j;
                }
                else if(map[i][j] == 'D')
                {
                    di = i;
                    dj = j;
                }
                else if(map[i][j] == 'X')
                    wall++;
            }
            getchar();
        }
        if(n*m-wall<=t)
        {
            printf("NO\n");
            continue;
        }
        flag = 0;
        map[si][sj] = 'X';
        dfs(si,sj,0);
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }


    return 0;
}

你可能感兴趣的:(ACM 搜索 hdu1010 Tempter of the Bone)