HDU 2122 Ice_cream’s world III(最小生成树Kruskal)

Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.

Sample Input
2 1
0 1 10

4 0

Sample Output
10

impossible

本题的题意就是问你能不能找到一个最小生成树,如果找到最小生成树的话,最小生成树的值是多少。因为之前对并查集的了解还是可以的,所以学起来最小生成树的话还是蛮简单的。

下面是AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int pre[1005];

struct node
{
    int x,y,val;
}a[10005];

int fin(int x)
{
    if(pre[x]==x)
    {
        return x;
    }
    else
    {
        pre[x]=fin(pre[x]);
        return pre[x];
    }
}

void join(int x,int y)
{
    int t1=fin(x);
    int t2=fin(y);
    if(t1!=t2)
    {
        pre[t1]=t2;
    }
}

void init(int n)
{
    for(int i=0;i<=n;i++)
    {
        pre[i]=i;
    }
}

bool cmp(node b,node c)
{
    return b.val<c.val;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        init(n);
        int sum=0,k=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d %d %d",&a[i].x,&a[i].y,&a[i].val);
        }
        sort(a,a+m,cmp);
        for(int i=0;i<m;i++)
        {
            if(fin(a[i].x)!=fin(a[i].y))
            {
                k++;
                sum+=a[i].val;
                join(a[i].x,a[i].y);
            }
        }
        if(k==n-1)//如果形成了最小生成树
        {
            printf("%d\n\n",sum);
        }
        else printf("impossible\n\n");
    }
    return 0;
}

你可能感兴趣的:(HDU,kruskal)