【辗转相除法】HDU1019Least Common Multiple

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1019

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
   
   
   
   
2 3 5 7 15 6 4 10296 936 1287 792 1
 

Sample Output
   
   
   
   
105 10296

代码:

#include<iostream>
#include<string>
#include<algorithm>
#define LL long long
using namespace std;
LL gcd(LL a,LL b)
{
    return b?gcd(b,a%b):a;
}
int main()
{
    int t,m;
    cin.sync_with_stdio(false);
    cin>>t;
    while(t--){
        cin>>m;
        LL sum=1,a;
        for(int i=0;i<m;i++){
            cin>>a;
            sum=sum/gcd(sum,a)*a;
        }
        cout<<sum<<endl;
    }
    return 0;
}


你可能感兴趣的:(【辗转相除法】HDU1019Least Common Multiple)