POJ——3061Subsequence(尺取法)

Subsequence
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11048   Accepted: 4571

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

尺取法入门题目,对于我这个大菜鸟有很大帮助啊

代码:

#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<sstream>
#include<cstring>
#include<cstdio>
#include<string>
#include<deque>
#include<cmath>
#include<queue>
#include<set>
#include<map>
using namespace std;
int main (void)
{
	int n,i,j,t,l,r,goal,minm;
	scanf("%d",&t);
	while (t--)
	{
		scanf("%d%d",&n,&goal);
		int *list=new int[n+1];
		for (i=1; i<=n; i++)
		{
			scanf("%d",&list[i]);
		}
		l=r=1;
		minm=100000009;
		int temp=0;
		while (1)
		{
			while (r<=n&&temp<goal)
			{
				temp+=list[r++];
			}
			if(temp<goal)
				break;
			minm=min(r-l,minm);
			temp-=list[l++];
		}
		if(minm==100000009)
			printf("0\n");
		else	
			printf("%d\n",minm);
		delete []list;
	}
	return 0;
}

你可能感兴趣的:(POJ——3061Subsequence(尺取法))