UVA 674 coin change

Description

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input 

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output 

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.  

Sample Input 

11
26

Sample Output 

4
13


DP题,有点贪心思想;

枚举一类钱出现的可能性,

则当前状态是上一种钱币的可能性;

且让DP【0】=1;

 f[i, v] = f[i-1, v] + f[i, v-c[i]].  表示前i种钱币的方法v

#include <bits/stdc++.h>
using namespace std ;
int a[5]={1,5,10,25,50};
int dp[500000];
int main()
{
	dp[0]=1;
	for(int i = 0;i<5;i++)
	{
		for(int j =a[i];j<=8000;j++)
		{
			dp[j]+=dp[j-a[i]];
		}
	}
	int n ;
	while(cin>>n)
	{
		cout<<dp[n]<<endl;
	}
}



你可能感兴趣的:(UVA 674 coin change)