poj 1703 Find them, Catch them(种类并查集)

链接:

http://poj.org/problem?id=1703


题目:

Find them, Catch them
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 22289   Accepted: 6648

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18


分析与总结:

做过一些的带权并查集,再来做所谓的“种类并查集",发现好像就顿悟了。

种类并查集与带权并查集实质上的差别并不大, 关键的区别就是种类并查集只是带权并查集再弄个%取余操作而已,然后余数就表示他属于哪个种类。

这题只有两个种类,也就是只有0和1两种, 对于两个不同的种类,那么之间的权值是相差1的,所以按照带权并查集的方法做加上1,然后取余2即可。



代码:

#include<cstdio>

const int N = 100005;
int n, m, f[N], rank[N];

inline void init(){
    for(int i=1; i<=n; ++i)
        f[i]=i,rank[i]=0;
}

int find(int x){
    if(x==f[x])return f[x];
    int fa=f[x];
    f[x] = find(f[x]);
    rank[x] = (rank[x]+rank[fa])&1;
    return f[x];
}

inline bool Union(int x,int y){
    int a=find(x), b=find(y);
    if(a==b) return false;
    f[b] = a;
    rank[b] = (rank[x]-rank[y]+1)&1;
}

int main(){
    int T,a,b,fa,fb;
    char ch;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d%*c",&n,&m);
        init();
        for(int i=0; i<m; ++i){
            scanf("%c%d%d%*c",&ch,&a,&b);
            if(ch=='D'){
                Union(a,b);
            }
            else{
                fa = find(a), fb=find(b);
                if(fa==fb){
                    if(rank[a]==rank[b]) puts("In the same gang.");
                    else puts("In different gangs.");
                }
                else
                    puts("Not sure yet.");
            }
        }
    }
    return 0;
}


——  生命的意义,在于赋予它意义。

          
     原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)



你可能感兴趣的:(poj 1703 Find them, Catch them(种类并查集))