POJ 3061 Subsequence (尺取)

Language:
Subsequence
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10993   Accepted: 4545

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source

Southeastern Europe 2006



题意:给你一个序列,求最短的连续的大于一个数的序列和

思路:尺取法,不知道的可以看一下


ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<set>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 1010000
#define ll long long
#define INF 0xfffffff
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1)
#define eps 1e-8
using namespace std;
ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
ll powmod(ll a,ll b,ll MOD){ll ans=1;while(b){if(b%2)ans=ans*a%MOD;a=a*a%MOD;b/=2;}return ans;}
double dpow(double a,ll b){double ans=1.0;while(b){if(b%2)ans=ans*a;a=a*a;b/=2;}return ans;}
//head
int a[MAXN];
int main()
{
	int t,i;
	scanf("%d",&t);
	while(t--)
	{
		int n,m;
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
		scanf("%d",&a[i]);
		int ans=INF,l=0,r=0;
		int sum=0;
		while(1)
		{
			while(sum<m&&r<n)
			{
				sum+=a[r];
				r++;
			}
			if(sum<m)
			break;
			while(sum>=m&&l<=r)
			{
				sum-=a[l];
				l++;
			}
			ans=min(ans,r-l+1);
		}
		if(ans==INF)
		printf("0\n");
		else
		printf("%d\n",ans);
	}
	return 0;
}


你可能感兴趣的:(POJ 3061 Subsequence (尺取))