Uva 442 Matrix Chain Multiplication

Matrix Chain Multiplication
Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Description

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n (  ), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125
 
   
 
   
用栈解决问题;
由于严格地遵守格式;
只要遇到矩阵压入栈,遇到)就弹出两个矩阵,运算后,再压入栈;
矩阵可以相乘的条件是前一个矩阵的列数等于后一个矩阵的行数;
 
   
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<stack>
using namespace std;
struct Matrix
{
    int x;
    int y;
}matrix[26];
stack<Matrix> s;
int main()
{
    int n;
    scanf("%d",&n);
    char c;
    for(int i=0;i<n;++i)
    {
        scanf(" %c",&c);
        scanf("%d %d",&matrix[c-'A'].x,&matrix[c-'A'].y);
    }
    string str;
    while(cin>>str)
    {
        bool flag=0;
        int ans=0;
        for(int i=0;i<str.length();++i)
        {
            if(str[i]<='Z'&&str[i]>='A')
            {
                s.push(matrix[str[i]-'A']);
            }
            else if(str[i]==')')
            {
                Matrix t1,t2;
                t2.x=s.top().x;
                t2.y=s.top().y;
                s.pop();
                t1.x=s.top().x;
                t1.y=s.top().y;
                s.pop();
                //cout<<t1.x<<" "<<t1.y<<endl;
                //cout<<t2.x<<" "<<t2.y<<endl;
                if(t1.y!=t2.x)
                {
                    flag=1;
                    break;
                }
                else
                {
                    ans+=t1.x*t1.y*t2.y;
                    Matrix temp;
                    temp.x=t1.x;
                    temp.y=t2.y;
                    s.push(temp);
                }
            }
        }
        if(flag) printf("error\n");
        else printf("%d\n",ans);
    }
    return 0;
}


你可能感兴趣的:(uva)