HDU 5366 The mook jong 递推 动态规划

The mook jong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 209    Accepted Submission(s): 154


Problem Description
![](../../data/images/C613-1001-1.jpg)

ZJiaQ want to become a strong man, so he decided to play the mook jong。ZJiaQ want to put some mook jongs in his backyard. His backyard consist of n bricks that is 1*1,so it is 1*n。ZJiaQ want to put a mook jong in a brick. because of the hands of the mook jong, the distance of two mook jongs should be equal or more than 2 bricks. Now ZJiaQ want to know how many ways can ZJiaQ put mook jongs legally(at least one mook jong).
 

Input
There ar multiply cases. For each case, there is a single integer n( 1 < = n < = 60)
 

Output
Print the ways in a single line for each case.
 

Sample Input
   
   
   
   
1 2 3 4 5 6
 

Sample Output
   
   
   
   
1 2 3 5 8 12
 

Source
BestCoder Round #50 (div.2) 

令f[i]为最后一个木人桩摆放在i位置的方案,令s[i]为f[i]的前缀和,即s[i]=f[0]+f[1]+...+f[i]。很容易就能想到f[i]=s[i-3]+1,因为最后一个木人放到最后一个位置,因此只有i-3个木人是可用的,再加上最后一种情况,s[i]=s[i-1]+f[i],而s[n]即是所求答案。本题唯一一个值得注意的点就是当n接近60时会爆int。


/*递推*/
#include <iostream>
using namespace std;

int main()
{
    int n,i;
    long long s[70],f[70];//s[i]表示i个木桩时的结果,f[i]表示把最后一个木桩放到第i个位置的方案数
    while(cin>>n)
    {
        s[1]=1;
        s[2]=2;
        s[3]=3;
        f[1]=f[2]=f[3]=1;
        for(i=4;i<=n;i++)
        {
            f[i]=s[i-3]+1;
            s[i]=s[i-1]+f[i];
        }
        cout<<s[n]<<endl;
    }


    return 0;
}




你可能感兴趣的:(动态规划,HDU,the,递推,5366,mook,jong)