POJ 2955 Brackets


简单的区间DP。。。

Brackets
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2518   Accepted: 1300

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source

Stanford Local 2004


#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

char str[220];
int dp[220][220];

int main()
{
while(scanf("%s",str)!=EOF)
{
	if(str[0]=='e'&&str[1]=='n'&&str[2]=='d') break;
	int n=strlen(str);
	memset(dp,0,sizeof(dp));
	for(int len=2;len<=n;len++)
	{
		for(int i=0;i+len-1<n;i++)
		{
			int j=i+len-1;
			if((str[i]=='('&&str[j]==')')||(str[i]=='['&&str[j]==']'))
			{
				dp[i][j]=dp[i+1][j-1]+1;
			}
			dp[i][j]=max(max(dp[i+1][j],dp[i][j-1]),dp[i][j]);
			for(int k=i;k<=j;k++)
				dp[i][j]=max(dp[i][k]+dp[k+1][j],dp[i][j]);
		}
	}
	printf("%d\n",2*dp[0][n-1]);
}
	return 0;
}



你可能感兴趣的:(POJ 2955 Brackets)