丑数问题 hdu— — Humble Numbers

Humble Numbers

时间限制: 1000ms
内存限制: 32768KB
HDU       ID:  1058
64位整型:      Java 类名:

题目描述

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence

输入

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

输出

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

样例输入

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

样例输出

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

题意:若一个数的所有素因子是2、3、5、7中的一个或多个,则这个数成为Humble数。求第n个Humble数是多少

分析:若一个数是Humble数,则它的2、3、5、7倍仍然是Humble数。

设a[i]为第i个Humble数,则a[n] = min(2*a[b2], 3*a[b3], 5*a[b5], 7*a[b7]), b2、b3、b5、b7在不断更新


方法一:

从1为"始祖",剩下的所有数,其实都是在此基础上乘以2,3,5,7演化出来的

代码主要语句:num[i]=min(num[a]*2,min(num[b]*3,min(num[c]*5,num[d]*7)))


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int num[6000];
int main()
{
	num[1]=1;
	int a=1,b=1,c=1,d=1;
	for(int i=2;i<=5845;i++){
		num[i]=min(num[a]*2,min(num[b]*3,min(num[c]*5,num[d]*7)));
		if(num[i]==num[a]*2)	a++;
		if(num[i]==num[b]*3)	b++;
		if(num[i]==num[c]*5)	c++;
		if(num[i]==num[d]*7)	d++;	
	}
	int n;
	while(~scanf("%d",&n)){
		if(n==0)	break;
		if(n%10==1 && n%100!=11)	printf("The %dst humble number is %d.\n",n,num[n]);
        else if(n%10==2&& n%100!=12)        printf("The %dnd humble number is %d.\n",n,num[n]);
        else if(n%10==3&& n%100!=13)        printf("The %drd humble number is %d.\n",n,num[n]);
        else           printf("The %dth humble number is %d.\n",n,num[n]);
	}	
	return 0;
}


方法二:

用2,3,5,7循环来求第i个f[i],第i个f[i]必定等于前i-1个数中其中一个数与{2,3,5,7}中其中一个的乘积

其中  f[i]只能等于2000000001,具体为啥我也不清楚

#include<stdio.h>
long long f[5843];
int main()
{
	int prime[4]={2,3,5,7};
	f[1]=1;
	for(int i=2;i<=5842;i++){
		f[i]=2000000001;
		for(int j=0;j<4;j++){
			for(int k=i-1;k>=1;k--){
				if(f[k]*prime[j] <= f[i-1])	break;
				if(f[k]*prime[j] < f[i])
					f[i]=f[k]*prime[j];				
			}
		}
	}
	int n;
	while(~scanf("%d",&n)){
		if(n==0)	break;
		if(n%10==1 && n%100!=11)	printf("The %dst humble number is %d.\n",n,f[n]);
        else if(n%10==2&& n%100!=12)        printf("The %dnd humble number is %d.\n",n,f[n]);
        else if(n%10==3&& n%100!=13)        printf("The %drd humble number is %d.\n",n,f[n]);
        else           printf("The %dth humble number is %d.\n",n,f[n]);
	}	 
	return 0;
}


你可能感兴趣的:(dp)