hdoj 2026 首字母变大写 (字符串)

首字母变大写

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47368    Accepted Submission(s): 26195


Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 

Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 

Output
请输出按照要求改写后的英文句子。
 

Sample Input
   
   
   
   
i like acm i want to get an accepted
 

Sample Output
   
   
   
   
I Like Acm I Want To Get An Accepted
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
    char a[110];
    while (gets(a))
    {
        a[0]=a[0]-32;
        int l=strlen(a);
        for(int i=1;i<l;i++)
        {
            if(a[i-1]==' ')
            {
                a[i]=a[i]-32;
            }
        }
            printf("%s\n",a);
    }
    return 0;
}


你可能感兴趣的:(hdoj 2026 首字母变大写 (字符串))