Pat(Advanced Level)Practice--1031(Hello World for U)

Pat1031代码

题目描述:

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1 characters, then left to right along the bottom line with n 2 characters, and finally bottom-up along the vertical line with n 3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n 1 = n 3 = max { k| k <= n 2 for all 3 <= n 2 <= N } with n 1 + n 2 + n 3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor

AC代码:
#include<cstdio>
#include<cstring>
#define MAX 100

using namespace std;

int main(int argc,char *argv[])
{
	int len;
	char str[MAX];
	int i,j;
	int n1,n2,n3;
	scanf("%s",str);
	len=strlen(str);
	n1=n3=(len+2)/3;
	n2=(len+2)%3+n1;
	for(i=0;i<n1;i++)
	{
		printf("%c",str[i]);
		if(i<n1-1)
		{
			for(j=3;j<=n2;j++)
				printf(" ");
		}
		else
		{
			for(j=3;j<=n2;j++)
				printf("%c",str[i+j-2]);
		}
		printf("%c\n",str[len-i-1]);
	}

	return 0;
}


你可能感兴趣的:(C++,pat,基础题,advance)