Flip Game(POJ_1753)

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it’s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

Choose any one of the 16 pieces.
Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here “b” denotes pieces lying their black side up and “w” denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters “w” or “b” each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it’s impossible to achieve the goal, then write the word “Impossible” (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

第一遍代码有很多漏洞,测数据的时候测出来好多。。总的来说就是递归没学好+粗心QAQ

代码

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

char s[5];
int flag=0;

int all(int str[5][5])
{
    for(int i=0; i<4; i++)
    {
        for(int j=0; j<4; j++)
        {
            if(str[i][j]!=str[0][0])
                return 0;
        }
    }
    return 1;
}

void flip(int i,int j,int str[5][5])
{
    str[i][j]=!str[i][j]; //之前忘了把源点翻转了。。。光翻了周围的点QAQ
    if(i!=0)
        str[i-1][j]=!str[i-1][j];
    if(i!=3)
        str[i+1][j]=!str[i+1][j];
    if(j!=0)
        str[i][j-1]=!str[i][j-1];
    if(j!=3)
        str[i][j+1]=!str[i][j+1];
}

void dfs(int i,int j,int k,int f,int str[5][5])
{
    if(f==k)
    {
        if(all(str))
        {
            printf("%d\n",k);
            flag=1;
        }
        return ;
    }
    if(i>3) return ; //一开始边界没处理好,在WA&RE上徘徊
    if(!flag)
    {
        if(j==3)
        {
            if(i!=3)
            {
                dfs(i+1,0,k,f,str);
            }
            flip(i,j,str);
            dfs(i+1,0,k,f+1,str);//一开始并没有想着再把它翻回来,
            flip(i,j,str); //以为数组不会变。。后来发现是错的。。。
        }
        else
        {
            dfs(i,j+1,k,f,str);
            flip(i,j,str);
            dfs(i,j+1,k,f+1,str);
            flip(i,j,str);
        }
    }
    return ;
}

int main()
{
    int str[5][5];
    for(int i=0; i<4; i++)
    {
        scanf("%s",s);
        for(int j=0; j<4; j++)
        {
            if(s[j]=='b')
                str[i][j]=1;
            else
                str[i][j]=0;
        }
    }
    for(int i=0; i<=16; i++)
    {
        int f=0;
        dfs(0,0,i,f,str);
        if(flag)
            break;
    }
    if(!flag)
        printf("Impossible\n");
    return 0;
}

附上当年渣代码的链接,真是想不通以前是用什么脑袋做的题,现在完全看不懂o(╯□╰)o
->渣渣渣渣渣

你可能感兴趣的:(Flip Game(POJ_1753))