hdoj 5477 A Sweet Journey 【二分】



A Sweet Journey

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 302    Accepted Submission(s): 163


Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice) 

hdoj 5477 A Sweet Journey 【二分】_第1张图片
 

Input
In the first line there is an integer t ( 1t50 ), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers:  Li,Ri , which represents the interval  [Li,Ri]  is swamp.
1n100,1L105,1A10,1B101Li<RiL .
Make sure intervals are not overlapped which means  Ri<Li+1  for each i ( 1i<n ).
Others are all flats except the swamps.
 

Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
 

Sample Input
       
       
       
       
1 2 2 2 5 1 2 3 4
 

Sample Output
       
       
       
       
Case #1: 0
 



题意:一个人要骑车过一个[0, L]的区间,区间里面有n个沼泽其余全是平坦的道路。第i个沼泽的区间为[l[i], r[i]],所有沼泽都不会重叠且r[i] < l[i+1]。已知骑车过沼泽每单位长度需要花费a点力气,走平路每单位长度可以收获b点力气。问你这个人至少需要准备的力气。。。



本身模拟比较弱,直接上了二分。




AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 100000+1
using namespace std;
int s[MAXN], e[MAXN];
int n, L, a, b;
bool judge(int d)
{
    int pre = 0;
    for(int i = 1; i <= n; i++)
    {
        d += (s[i] - pre) * b;
        d -= (e[i] - s[i]) * a;
        if(d < 0)
            return false;
        pre = e[i];
    }
    return true;
}
int main()
{
    int t, k = 1;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d%d%d", &n, &a, &b, &L);
        for(int i = 1; i <= n; i++)
            scanf("%d%d", &s[i], &e[i]);
        int l = 0, r = L * 10+1, mid;
        int ans;
        while(r >= l)
        {
            int mid = (l + r) >> 1;
            if(judge(mid))
                ans = mid, r = mid - 1;
            else
                l = mid + 1;
        }
        printf("Case #%d: %d\n", k++, ans);
    }
    return 0;
}


你可能感兴趣的:(hdoj 5477 A Sweet Journey 【二分】)