joj1424

 1424: Coin Change

Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
3s 8192K 700 243 Standard

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input

11
26

Sample Output

4
13


This problem is used for contest: 81  148  183 

Submit / Problem List / Status / Discuss


#include<stdio.h>
#include<iostream>
using namespace std;
int main()
{
    int c1[7489+10]={0};
    int c2[7489+10]={0};
    int a[]={1,5,10,25,50};
    int n=7489;
    for(int i=0;i<=n;i++)
    {
        c1[i]=1;c2[i]=0;
    }
    for(int i=1;i<5;i++)
    {
        for(int j=0;j<=n;j++)
        {
            for(int k=0;k+j<=n;k+=a[i])
            {
                c2[j+k]+=c1[j];
            }
        }
        for(int k=0;k<=n;k++)
        {
            c1[k]=c2[k];
            c2[k]=0;
        }
    }
    while(scanf("%d",&n)==1)
    {
        cout<<c1[n]<<endl;
    }
    return 0;
}
//这是一个母函数问题。通过利用指数来表示数字n,通过系数来表示达到n总共有多少方式。。。
//关于母函数的详细解说可以看我博客里面转载的文章。。。。

你可能感兴趣的:(joj1424)