joj1063

 1063: A Funny Game

Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
3s 8192K 696 260 Standard

1st JOJ Cup Online VContest Warmup Problem

Tom and Jack are on the train. The journey is too dull so much so that both of them are eager to find a way to fritter away the time. Tom is a student of mathematics department. He proposes a funny game to play with Jack. First pile up N chips where 1<N<100000, then Jack takes away at most P=N-1 chips from the pile. After that, Tom takes away at most(or equals) Q=2*P chips from the pile. Then it turns to Jack again, he takes away at most(or equals) P=2*Q. Each time both of them have to take away at least 1 chip. In the same way, the process continues and who takes away the last chip wins the game. Jack knows there must be something tricky in the game, so he's decided to write a program to check whether there exists a win-strategy(no matter how many chips Tom takes away each time, Jack will win) for himself for a specific N. You know Jack is very good at programming, so solving this problem doesn't take him too much time. Do you know how he does?

Input Specification

The input consists of several lines, each of which consists of an integer N. The last line of the input is 0, which you shouldn't process.

Output Specification

For each N, you should output either YES or NO. If there exists a win-strategy for Jack, output YES. Otherwise output NO.

Sample Input

2
3
4
5
1000
0

Sample Output

NO
NO
YES
NO
YES

Submit / Problem List / Status / Discuss





#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;


int f[100000]={0};
int main()
{
    memset(f,0,sizeof(f));
    int v=2;
    int u=3;
    f[2]=1;
    f[3]=1;
    while(u<=100000&&v<=100000)
    {
        f[u]=1;
        int temp=u+v;
        v=u;
        u=temp;
    }
    //for(int i=1;i<=19;i++)cout<<f[i]<<endl;
    int n;
    while(scanf("%d",&n),n)
    {
        if(f[n]==1)cout<<"NO"<<endl;
        else cout<<"YES"<<endl;
    }
    return 0;
}


这是一个斐波那契数列与博弈的应用详细情况可以看我博客中转载的斐波那契取石子博弈。。。

你可能感兴趣的:(Integer,equals,input,UP,each,output)