hdu2896 病毒侵袭

病毒侵袭

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4739    Accepted Submission(s): 1226


Problem Description
当太阳的光辉逐渐被月亮遮蔽,世界失去了光明,大地迎来最黑暗的时刻。。。。在这样的时刻,人们却异常兴奋——我们能在有生之年看到500年一遇的世界奇观,那是多么幸福的事儿啊~~
但网路上总有那么些网站,开始借着民众的好奇心,打着介绍日食的旗号,大肆传播病毒。小t不幸成为受害者之一。小t如此生气,他决定要把世界上所有带病毒的网站都找出来。当然,谁都知道这是不可能的。小t却执意要完成这不能的任务,他说:“子子孙孙无穷匮也!”(愚公后继有人了)。
万事开头难,小t收集了好多病毒的特征码,又收集了一批诡异网站的源码,他想知道这些网站中哪些是有病毒的,又是带了怎样的病毒呢?顺便还想知道他到底收集了多少带病毒的网站。这时候他却不知道何从下手了。所以想请大家帮帮忙。小t又是个急性子哦,所以解决问题越快越好哦~~
 

Input
第一行,一个整数N(1<=N<=500),表示病毒特征码的个数。
接下来N行,每行表示一个病毒特征码,特征码字符串长度在20—200之间。
每个病毒都有一个编号,依此为1—N。
不同编号的病毒特征码不会相同。
在这之后一行,有一个整数M(1<=M<=1000),表示网站数。
接下来M行,每行表示一个网站源码,源码字符串长度在7000—10000之间。
每个网站都有一个编号,依此为1—M。
以上字符串中字符都是ASCII码可见字符(不包括回车)。
 

Output
依次按如下格式输出按网站编号从小到大输出,带病毒的网站编号和包含病毒编号,每行一个含毒网站信息。
web 网站编号: 病毒编号 病毒编号 …
冒号后有一个空格,病毒编号按从小到大排列,两个病毒编号之间用一个空格隔开,如果一个网站包含病毒,病毒数不会超过3个。
最后一行输出统计信息,如下格式
total: 带病毒网站数
冒号后有一个空格。
 

Sample Input
   
   
   
   
3 aaa bbb ccc 2 aaabbbccc bbaacc
 

Sample Output
   
   
   
   
web 1: 1 2 3 total: 1
 

Source
2009 Multi-University Training Contest 10 - Host by NIT
 

Recommend
gaojie



AC自动机,这次1Y。

#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
using namespace std;

typedef struct
{
    int fail,word;
    int next[100];
}Tree;

Tree tree[1000005];
char str[10005];
queue <int> q;
int ans[10];
int up,num;

bool cmp(int x,int y)
{
    return x<y;
}

void Add(char *str,int t)
{
    int i,j,now,n;
    now=0;
    n=strlen(str);
    for (i=0;i<n;i++)
    {
        if (tree[now].next[str[i]-30]==-1)
        {
            tree[now].next[str[i]-30]=up;
            tree[up].word=-1;
            memset(tree[up].next,-1,sizeof(tree[up].next));
            up++;
        }
        now=tree[now].next[str[i]-30];
    }
    tree[now].word=t;
}

void BFS()
{
    int i,j,tag,t,p;
    q.push(0);
    while(!q.empty())
    {
        tag=q.front();
        q.pop();
        for (i=0;i<100;i++)
        {
            if (tree[tag].next[i]==-1) continue;
            t=tree[tag].next[i];
            q.push(t);
            if (tag==0)
            {
                tree[t].fail=0;
                continue;
            }
            p=tree[tag].fail;
            while(tree[p].next[i]==-1 && p!=0)
            {
                p=tree[p].fail;
            }
            if (tree[p].next[i]!=-1)
            {
                tree[t].fail=tree[p].next[i];
            }
            else
            {
                tree[t].fail=0;
            }
        }
    }
}

void Count(char *str)
{
    int i,j,n,now,tag;
    n=strlen(str);
    now=0;
    for (i=0;i<n;i++)
    {
        while(tree[now].next[str[i]-30]==-1 && now!=0)
        {
            now=tree[now].fail;
        }
        if (tree[now].next[str[i]-30]!=-1)
        {
            now=tree[now].next[str[i]-30];
        }
        tag=now;
        while(tag!=0)
        {
            if (tree[tag].word!=-1)
            {
                ans[num++]=tree[tag].word;
            }
            tag=tree[tag].fail;
        }
    }
}

int main()
{
    int i,j,n,m,cnt;
    while(scanf("%d",&n)!=EOF)
    {
        up=1;
        memset(tree[0].next,-1,sizeof(tree[0].next));
        for (i=0;i<n;i++)
        {
            scanf("%s",str);
            Add(str,i);
        }
        BFS();
        scanf("%d",&m);
        cnt=0;
        for (i=0;i<m;i++)
        {
            getchar();
            gets(str);
            num=0;
            Count(str);
            if (num==0) continue;
            sort(ans,ans+num,cmp);
            printf("web %d: ",i+1);
            for (j=0;j<num-1;j++)
            {
                printf("%d ",ans[j]+1);
            }
            printf("%d\n",ans[j]+1);
            cnt++;
        }
        printf("total: %d\n",cnt);
    }
    return 0;
}










你可能感兴趣的:(struct,tree,ini,input,UP,Training)