poj 3159 candies

Candies
Time Limit: 1500MS   Memory Limit: 131072K
Total Submissions: 27436   Accepted: 7560

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers ABand c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

Source

POJ Monthly--2006.12.31, Sempr


题目大意:flymouse是幼稚园班上的班长,一天老师给小朋友们买了一堆的糖果,由flymouse来分发。flymouse希望自己分得的糖果数尽量多于snoopy。对于其他小朋友而言,则必须自己得到的糖果不少于班上某某,给出m个这种约束关系(u,v, w)即同学u的糖果数不能比同学v的糖果数少w。问flymouse最多能多snoopy几个糖果。

题解:约束差分。自己水平有限,我理解的约束差分就是把一些不等式的限制转化成一个有向图,利用单源最短路来解决。(u,v,w) d[v]<=d[u]+w  有点类似于求最短路时的三角不等式,于是就连一条从u 到v的有向边,权值为w。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int strack[30003],dis[30003],can[30003];
int tot,next[300003],point[30003],v[300003],w[300003];
int n,m;
void add(int x,int y,int z)
{
  tot++; next[tot]=point[x]; point[x]=tot; v[tot]=y; w[tot]=z;
}
void spfa(int s,int t)
{
  memset(dis,0x7f,sizeof(dis));
  memset(can,0,sizeof(can));
  dis[s]=0; can[s]=1; 
  int k=0; strack[++k]=s;
  while (k)
   {
   	 int now=strack[k--];
   	 for (int i=point[now];i;i=next[i])
   	  if (dis[v[i]]>dis[now]+w[i])
   	   {
   	   	 dis[v[i]]=dis[now]+w[i];
   	   	 if (!can[v[i]])
   	   	  {
   	   	  	can[v[i]]=1;
   	   	  	strack[++k]=v[i];
   	   	  }
   	   }
   	 can[now]=0;
   }
}
int main()
{
  scanf("%d%d",&n,&m);
  for (int i=1;i<=m;i++)
   {
   	 int x,y,z;  scanf("%d%d%d",&x,&y,&z); 
   	 add(x,y,z);
   }
  spfa(1,n);
  printf("%d",dis[n]);
}


你可能感兴趣的:(poj 3159 candies)