joj1583

 1583: Let Me Count The Ways

Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
3s 8192K 551 231 Standard

After making a purchase at a large department store, Mel's change was 17 cents. He received 1 dime, 1 nickel, and 2 pennies. Later that day, he was shopping at a convenience store. Again his change was 17 cents. This time he received 2 nickels and 7 pennies. He began to wonder ' "How many stores can I shop in and receive 17 cents change in a different configuration of coins? After a suitable mental struggle, he decided the answer was 6. He then challenged you to consider the general problem.

Write a program which will determine the number of different combinations of US coins (penny, nickel, dime, quarter, half-dollar) which may be used to produce a given amount of money.

Input

The input will consist of a set of numbers between 0 and 99 inclusive, one per line in the input file.

Output

The output will consist of the appropriate statement from the selection below on a single line in the output file for each input value. The number m is the number your program computes, n is the input value.

There are m ways to produce n cents change.

There is only 1 way to produce n cents change.

Sample input

17 
11
4

Sample output

There are 6 ways to produce 17 cents change. 
There are 4 ways to produce 11 cents change. 
There is only 1 way to produce 4 cents change.

This problem is used for contest: 109 

Submit / Problem List / Status / Discuss



#include<stdio.h>
#include<iostream>
using namespace std;
int c1[100];
int c2[100];
int a[]={1,5,10,25,50};
int main()
{
    for(int i=0;i<=100;i++)
    {
        c1[i]=1;c2[i]=0;
    }
    int n=100;
    for(int i=1;i<=4;i++)
    {
        for(int j=0;j<=n;j++)
        {
            for(int k=0;k+j<=n;k+=a[i])
            {
                c2[j+k]+=c1[j];
            }
        }
        for(int i=0;i<=n;i++)
        {
            c1[i]=c2[i];
            c2[i]=0;
        }
    }
    while(scanf("%d",&n)==1)
    {
        if(c1[n]>1)
        cout<<"There are "<<c1[n]<<" ways to produce "<<n<<" cents change."<<endl;
        else
        cout<<"There is only "<<c1[n]<<" way to produce "<<n<<" cents change."<<endl;
    }
    return 0;
}

//跟1424一样的都是母函数应用,具体的可以看我转载的母函数详解


你可能感兴趣的:(joj1583)