Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 12908    Accepted Submission(s): 5774


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
   
   
   
   
2 100 -4
 

Sample Output
   
   
   
   
1.6152 No solution!
#include<stdio.h>
double m;
double f(double x)
{
	return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		
		double l,r,s,h;
		scanf("%lf",&m);
		if(f(0)<=m&&f(100)>=m)
		{
			l=0,r=100;
			while(r-l>1e-7)
			{
				h=(r+l)/2;
				s=f(h);
				if(s>m)
				r=h;
				else
				l=h;
			}
			printf("%.4lf\n",(r+l)/2);
		}
		else printf("No solution!\n");
	}
		return 0;
}


你可能感兴趣的:(Can you solve this equation?)