DP-HDU-1160-FatMouse's Speed

FatMouse’s Speed

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12405 Accepted Submission(s): 5446
Special Judge

Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m[n] then it must be the case that

W[m[1]] < W[m[2]] < … < W[m[n]]

and

S[m[1]] > S[m[2]] > … > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output
4
4
5
9
7

Source
Zhejiang University Training Contest 2001

这道题和求最长上升/下降子序列没什么区别,或者可以说成是求最长符合条件序列,序列元素构成的集合是样本的子集。

//
// main.cpp
// 基础DP1-J-FatMouse's Speed
//
// Created by 袁子涵 on 15/10/24.
// Copyright © 2015年 袁子涵. All rights reserved.
//
// 15ms 1604KB

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>

using namespace std;

typedef struct{
    int wt,spd,pre,num;
}mouse;

mouse mice[1005];
bool visit[1005];
int n=1,num=1;

int DP(int x)
{
    if (visit[x]) {
        return mice[x].num;
    }
    for (int i=1; i<=num; i++) {
        if (mice[i].wt<mice[x].wt && mice[i].spd>mice[x].spd && DP(i)+1>mice[x].num) {
            mice[x].num=mice[i].num+1;
            mice[x].pre=i;
        }
    }
    visit[x]=1;
    return mice[x].num;
}

void output(int x)
{
    if (mice[x].pre) {
        output(mice[x].pre);
    }
    printf("%d\n",x);
}

int main(int argc, const char * argv[]) {
    int tail=1;
    memset(visit, 0, sizeof(visit));
    while (scanf("%d%d",&mice[num].wt,&mice[num].spd)!=EOF && mice[num].wt!=0) {
        mice[num].pre=0;
        mice[num].num=1;
        num++;
    }
    for (int i=1; i<=num; i++) {
        if (DP(i)>n) {
            n=mice[i].num;
            tail=i;
        }
    }
    cout << n << endl;
    output(tail);
    return 0;
}

你可能感兴趣的:(c,dp)