【BFS】HDU1253胜利大逃亡

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1253

Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

【BFS】HDU1253胜利大逃亡_第1张图片
 

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
 

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
 

Sample Input
   
   
   
   
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
 

Sample Output
   
   
   
   
11

优先队列搜的话TLE到死。。。。看了下Discuss,大家都说用普通队列就能过,毫不犹豫的试了下,还真过了。。。。

估计是数据的问题吧,数据刚好可以一条线走到底的那种。

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
using namespace std;
int a[55][55][55];
int vis[55][55][55];
int A,B,C,T;
struct node
{
    int x,y,z,t;
    /*bool friend operator < (node a,node b)
    {
        return a.t>b.t;
    }*/
};
int dir[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,-1},{0,0,1}};
void bfs(int x,int y,int z)
{
    //priority_queue<node>q;
    queue<node>q;
    node st;
    st.x=x;
    st.y=y;
    st.z=z;
    st.t=0;
    vis[x][y][z]=1;
    q.push(st);
    while(!q.empty()){
        st=q.front();
        //st=q.top();
        q.pop();
        if(st.x==A-1&&st.y==B-1&&st.z==C-1&&st.t<=T)
        {
            printf("%d\n",st.t);
            //cout<<st.t<<endl;
            return ;
        }
        if(st.t>=T){
            printf("-1\n");
            return ;
        }
        for(int i=0;i<6;i++){
            node nt;
            nt.x=st.x+dir[i][0];
            nt.y=st.y+dir[i][1];
            nt.z=st.z+dir[i][2];
            nt.t=st.t+1;
            if(nt.x>=0&&nt.y>=0&&nt.z>=0&&nt.x<A&&nt.y<B&&nt.z<C&&a[nt.x][nt.y][nt.z]==0&&!vis[nt.x][nt.y][nt.z]){
                vis[nt.x][nt.y][nt.z]=1;
                q.push(nt);
            }
        }
    }
    printf("-1\n");
}
int main()
{
    int t;
    //cin.sync_with_stdio(false);
    scanf("%d",&t);
    while(t--){
        scanf("%d%d%d%d",&A,&B,&C,&T);
        memset(vis,0,sizeof(vis));
        for(int i=0;i<A;i++)            //  层数;
            for(int j=0;j<B;j++)        //  横坐标;
                for(int z=0;z<C;z++)    //  列坐标;
                    scanf("%d",&a[i][j][z]);
        bfs(0,0,0);
        //cout<<bfs(0,0,0)<<endl;
        //printf("%d\n",bfs(0,0,0));
    }
    return 0;
}


你可能感兴趣的:(【BFS】HDU1253胜利大逃亡)