poj2823Sliding Window【单调队列经典题】

Description

An array of size n ≤ 10 6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

POJ Monthly--2006.04.28, Ikki

比刚刚那个稍微复杂在删元素用序号控制,输出的时候也不用考虑有没有队首元素,因为肯定有啊,关于前k-1个元素的加入:正常加进去,不输出就得了啊

/***************
poj2823
2016.2.23
4088K	5391MS	C++	836B
***************/
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n,k,num[1000000],q[1000000],l,r,out;
int main()
{
   // freopen("cin.txt","r",stdin);
    while(~scanf("%d%d",&n,&k))
    {
        for(int i=1;i<=n;i++) scanf("%d",&num[i]);
        l=out=0,r=-1;
        for(int i=1;i<=n;i++)
        {
            while(l<=r&&num[q[r]]>num[i]) r--;
            q[++r]=i;
            while(i-q[l]>=k) l++;
            if(i>=k) printf("%d ",num[q[l]]);
        }
        printf("\n");
        l=out=0,r=-1;
        for(int i=1;i<=n;i++)
        {
            while(l<=r&&num[q[r]]<num[i]) r--;
            q[++r]=i;
            while(i-q[l]>=k) l++;
            if(i>=k) printf("%d ",num[q[l]]);
        }
        printf("\n");
    }
    return 0;
}


你可能感兴趣的:(poj2823Sliding Window【单调队列经典题】)