poj 3041 Asteroids

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input

3 4
1 1
1 3
2 2
3 2
Sample Output

2

最大匹配问题,跟杭电上的2063过山车一样,

#include<stdio.h>
#include<string.h>
#include <string>
#include <queue>
#include <iostream>
using namespace std;
int m,n,map[505][505];
int vis[505],link[505];
int find(int a)
{
    int i;
    for (i=1;i<=n;i++)
      {
       if (map[a][i]&&!vis[i])
          {
              vis[i]=1;
              if (link[i]==-1||find(link[i]))
              {
                  link[i]=a;
                  return 1;
              }
          }
      }
      return 0;
}
int main()
{
    int i,a,b,cnt=0;
    scanf("%d%d",&n,&m);
    while (m--)
    {
        scanf("%d%d",&a,&b);
        map[a][b]=1;
    }
    memset(link,-1,sizeof(link));
    for (i=1;i<=n;i++)
    {
        memset(vis,0,sizeof(vis));
        if (find(i))
            cnt++;
    }
    printf("%d\n",cnt);
    return 0;
}


你可能感兴趣的:(poj 3041 Asteroids)