uva 10954 Add All

原题:
Yup!! The problem name reflects your task; just add a set of numbers. But you may feel yourselves condescended, to write a C/C++ program just to add a set of numbers. Such a problem will simply question your erudition. So, lets add some flavor of ingenuity to it.
Addition operation requires cost now, and the cost is the summation of those two to be added. So,
to add 1 and 10, you need a cost of 11. If you want to add 1, 2 and 3. There are several ways
1 + 2 = 3, cost = 3
1 + 3 = 4, cost = 4
2 + 3 = 5, cost = 5
3 + 3 = 6, cost = 6
2 + 4 = 6, cost = 6
1 + 5 = 6, cost = 6
Total = 9
Total = 10
Total = 11
I hope you have understood already your mission, to add a set of integers so that the cost is minimal.
Input
Each test case will start with a positive number,
N
(2<=N<=5000) followed by
N
positive integers
(all are less than 100000). Input is terminated by a case where the value of
N
is zero. This case should
not be processed.
Output
For each case print the minimum total cost of addition in a single line.
SampleInput
3
1 2 3
4
1 2 3 4
0
SampleOutput
9
19
大意:
给你n个数,然后让你求和,每次求两个数的和是有代价的,代价就是两个数的和。现在问你所有数加起来代价最少是多少。

#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <cstdio>
#include <fstream>
#include <queue>
using namespace std;
//fstream input,output;
int n,ans,sum;
struct cmp
{
    bool operator() (const int a,const int b)
    {
        return a>b;
    }
};
priority_queue<int,vector<int>,cmp> pq;
int main()
{
    ios::sync_with_stdio(false);
// input.open("in.txt");
// output.open("out.txt");
    while(cin>>n,n)
    {
        int a;
        sum=ans=0;
        for(int i=0;i<n;i++)
        {
            cin>>a;
            pq.push(a);
        }
        while(!pq.empty())
        {
            sum=pq.top();
            pq.pop();
            if(!pq.empty())
            {
                sum+=pq.top();
                pq.pop();
            }
            ans+=sum;
            if(pq.empty())
                break;
            pq.push(sum);
            sum=0;
        }
        cout<<ans<<endl;
    }
// input.close();
// output.close();
    return 0;
}

解答:
裸的哈夫曼树,利用一个最小堆。每次把计算后的和放到堆里,然后调整弹出,继续求和即可。

你可能感兴趣的:(uva)