HDU 1014 Uniform Generator(水~)

Description
给定两个数step, mod然后利用给定的公式seed(x+1)=[seed(x)+step] %mod求seed数组,如果seed数组的前mod项组成的集合等于0~mod-1组成的集合就输出Good否则就输出Bad
Input
多组输入,每组用例占一行包括两个整数step和mod,以文件尾结束输入
Output
对于每组用例,如果求出的seed数组满足条件则输出Good,否则输出Bad,每组输出后跟一空行,输出的前10位输出step,第11~20位输出mod,然后是四个空格,第25位后输出Good/Bad Choicei
Sample Input
3 5
15 20
63923 99999
Sample Output
3 5 Good Choice

15 20 Bad Choice

63923 99999 Good Choice

Solution
水题
Code

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int step,mod;
    while(scanf("%d%d",&step,&mod)!=EOF)
    {
        int seed[111111];
        seed[0]=0;
        for(int i=1;i<mod;i++)//得到seed数组 
            seed[i]=(seed[i-1]+step)%mod;
        sort(seed,seed+mod);
        int flag=1;
        for(int i=0;i<mod;i++)//枚举集合元素判断两个集合是否相等 
            if(seed[i]!=i)
                flag=0;
        if(flag)//满足条件 
            printf("%10d%10d Good Choice\n\n",step,mod);
        else//不满足条件 
            printf("%10d%10d Bad Choice\n\n",step,mod);
    }
    return 0;
}

你可能感兴趣的:(HDU 1014 Uniform Generator(水~))