ZOJ 1484 Minimum Inversion Number


归并排序求逆序数。。。。


Minimum Inversion Number Time Limit: 2 Seconds       Memory Limit: 65536 KB

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.


Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.


Output

For each case, output the minimum inversion number on a single line.


Sample Input

10
1 3 6 9 0 8 5 7 4 2


Sample Output

16


Author:  CHEN, Gaoli
Source:  ZOJ Monthly, January 2003



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int a[5500],b[5500],t[5500],n,nixushu=0;

void merge_sort(int l,int r)
{
    if(l>=r) return;
    int m=(l+r)/2;
    merge_sort(l,m); merge_sort(m+1,r);
    int q=0,left=m-l+1,right=r-m,nl=0,nr=0;
    while(nl<left&&nr<right)
    {
        if(a[l+nl]<a[m+1+nr])
        {
            t[q]=a[l+nl];
            nl++;
        }
        else if(a[m+1+nr]<a[l+nl])
        {
            nixushu+=m-l-nl+1;
            t[q]=a[m+1+nr];
            nr++;
        }
        q++;
    }
    while(nl<left)
    {
        t[q]=a[l+nl]; q++; nl++;
    }
    while(nr<right)
    {
        t[q]=a[m+1+nr]; q++; nr++;
    }
    for(int i=l;i<=r;i++)
        a[i]=t[i-l];
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
            scanf("%d",a+i),b[i]=a[i];
        nixushu=0;
        merge_sort(0,n-1);
        int ans=nixushu,last=nixushu;
        for(int i=0;i<n;i++)
        {
            last=last+(n-1-b[i])-b[i];
            ans=min(ans,last);
        }
        printf("%d\n",ans);
    }
    return 0;
}




你可能感兴趣的:(ZOJ 1484 Minimum Inversion Number)