HDOJ 2136

Largest prime factor

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5565    Accepted Submission(s): 1961


Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
 

Input
Each line will contain one integer n(0 < n < 1000000).
 

Output
Output the LPF(n).
 

Sample Input
   
   
   
   
1 2 3 4 5
 

Sample Output
   
   
   
   
0 1 2 1 3
 

Author
Wiskey
 

Source
HDU 2007-11 Programming Contest_WarmUp
 

Recommend
威士忌

埃拉托色尼筛选法(输入一个一定范围内的自然数,返回小于这个自然数的所有素数(质数)) 
(1)先把1删除 
(2)读取队列中当前最小的数2,然后把2的倍数删去 
(3)读取队列中当前最小的数3,然后把3的倍数删去 
(4)读取队列中当前最小的数5,然后把5的倍数删去 
(5)如上所述直到需求的范围内所有的数均删除或读取 
由于本题需要经常读取素数位置,所以用埃拉托色尼筛选法是比较合适的。 为了适应本题,做一些改变。把2的倍数均设为1, 3的倍数设为2, 5的倍数设为3......
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
#include <stack>
#include <cctype>
#include <vector>
#include <queue>
#include <set>
#include <utility>

using namespace std;
//#define Online_Judge
#define outstars cout << "***********************" << endl;
#define clr(a,b) memset(a,b,sizeof(a))
#define lson l , mid  , rt << 1
#define rson mid + 1 , r , rt << 1 | 1
#define mid ((l + r) >> 1)
#define mk make_pair
#define FOR(i , x , n) for(int i = (x) ; i < (n) ; i++)
#define FORR(i , x , n) for(int i = (x) ; i <= (n) ; i++)
#define REP(i , x , n) for(int i = (x) ; i > (n) ; i--)
#define REPP(i ,x , n) for(int i = (x) ; i >= (n) ; i--)
const int MAXN = 2000010;
const long long LLMAX = 0x7fffffffffffffffLL;
const long long LLMIN = 0x8000000000000000LL;
const int INF = 0x7fffffff;
const int IMIN = 0x80000000;
#define eps 1e-8
#define mod 1000000007
typedef long long LL;
const double PI = acos(-1.0);
typedef double D;
typedef pair<int , int> pi;
///#pragma comment(linker, "/STACK:102400000,102400000")
int a[MAXN] , n;
int main()
{
    //ios::sync_with_stdio(false);
    #ifdef Online_Judge
        freopen("in.txt","r",stdin);
        freopen("out.txt","w",stdout);
    #endif // Online_Judge
    clr(a , -1);
    a[1] = 0;
    int cnt = 0;
    FOR(i , 2 , MAXN)
    {
        if(a[i] == -1)
        {
            cnt++;
            for(int j = i ; j < MAXN ; j+= i)
            {
                a[j] = cnt;
            }
        }
    }
    while(~scanf("%d" , &n))printf("%d\n" , a[n]);
    return 0;
}



你可能感兴趣的:(数论,ACM)