poj1276——Cash Machine(多重背包)

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 … nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input

735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10
Sample Output

735
630
0
0

动态规划,也算是多重背包问题吧。设dp[i]为是否可以获得金额为i的状态,可以的话dp[i]=1

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#define MAXN 100010
using namespace std;
struct Node
{
    int n,d;
};
Node a[20];
int dp[MAXN];
int main()
{
    int cash,N,i,j,k,max,tem;
    while(~scanf("%d%d",&cash,&N))
    {
        for(i=1; i<=N; ++i)
            scanf("%d%d",&a[i].n,&a[i].d);
        if(!cash)
            printf("0\n");
        else if(!N)
            printf("0\n");
        else
        {
            memset(dp,0,sizeof(dp));
            max=0;
            dp[0]=1;
            for(i=1; i<=N; ++i)
                for(j=max; j>=0; --j)
                {
                    if(dp[j])
                    {
                        for(k=1; k<=a[i].n; ++k)
                        {
                            tem=j+k*a[i].d;
                            if(tem>cash)
                                continue;
                            dp[tem]=1;
                            if(tem>max)
                                max=tem;
                        }
                    }
                }
            printf("%d\n",max);
        }
    }
    return 0;
}

你可能感兴趣的:(poj)