Can you find it?
Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 16442 Accepted Submission(s): 4178
Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
ac代码:
#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
int a[555],b[555],c[555],num[255555];//最好定义在外面吧
int main()
{
int n,m,k,sum,t,max,i,j;
int Case=1;
while(scanf("%d%d%d",&n,&m,&k)!=EOF)
{
for(i=0;i<n;i++)
scanf("%d",&a[i]);
for(i=0;i<m;i++)
scanf("%d",&b[i]);
for(i=0;i<k;i++)
scanf("%d",&c[i]);
sort(c,c+k);
int q=0;
for(i=0;i<n;i++)//先把前两排的数加起来
for(j=0;j<m;j++)
num[q++]=a[i]+b[j];
sort(num,num+q);//排序
scanf("%d",&t);
printf("Case %d:\n",Case++);
while(t--)
{
int bz=0;
scanf("%d",&max);
for(i=0;i<k;i++)
{
sum=max-c[i];
int low=0;
int high=q-1;
int mid=(low+high)/2;
while(low+1<high)//二分求
{
if(num[mid]>sum)
high=mid;
else if(num[mid]<sum)
low=mid;
else
{
bz=1;
break;
}
mid=(low+high)/2;
}
if(num[low]==sum||num[high]==sum)
{
bz=1;
}
if(bz)
{
break;
}
}
if(bz==0)
printf("NO\n");
else
printf("YES\n");
}
}
return 0;
}