Equivalent Sets
Time Limit: 12000/4000 MS (Java/Others) Memory Limit: 104857/104857 K (Java/Others)
Total Submission(s): 3611 Accepted Submission(s): 1258
Problem Description
To prove two sets A and B are equivalent, we can first prove A is a subset of B, and then prove B is a subset of A, so finally we got that these two sets are equivalent.
You are to prove N sets are equivalent, using the method above: in each step you can prove a set X is a subset of another set Y, and there are also some sets that are already proven to be subsets of some other sets.
Now you want to know the minimum steps needed to get the problem proved.
Input
The input file contains multiple test cases, in each case, the first line contains two integers N <= 20000 and M <= 50000.
Next M lines, each line contains two integers X, Y, means set X in a subset of set Y.
Output
For each case, output a single integer: the minimum steps needed.
Sample Input
Sample Output
4
2
Hint
Case 2: First prove set 2 is a subset of set 1 and then prove set 3 is a subset of set 1.
AC—code:
#include<cstdio>
#include<vector>
#include<stack>
#include<cstring>
#define min(a,b) a>b?b:a
#define INF 0x3f3f3f
#define MAXN 20005
#define MAXM 50005
using namespace std;
int low[MAXN],dfn[MAXN],eagenum,instack[MAXN],sccno[MAXN],scc_cnt,dfs_clock;
vector<int>scc[MAXN];
int head[MAXM];
stack<int>s;
struct Eage
{
int from,to,next;
}eage[MAXM];
void add(int a,int b)
{
eage[eagenum].from=a;
eage[eagenum].to=b;
eage[eagenum].next=head[a];
head[a]=eagenum++;
}
void tarjan(int u)
{
int v;
dfn[u]=low[u]=++dfs_clock;
s.push(u);
instack[u]=1;
for(int i=head[u];i!=-1;i=eage[i].next)
{
v=eage[i].to;
if(!dfn[v])
{
tarjan(v);
low[u]=min(low[u],low[v]);
}
else if(instack[v])
low[u]=min(low[u],dfn[v]);
}
if(low[u]==dfn[u])
{
scc_cnt++;
scc[scc_cnt].clear();
while(1)
{
v=s.top();
s.pop();
instack[v]=0;
sccno[v]=scc_cnt;
scc[scc_cnt].push_back(v);
if(u==v)
break;
}
}
}
vector<int>G[MAXN];
int out[MAXN],in[MAXN];
void suodian()
{
int i;
for(i=1;i<=scc_cnt;i++)
{
G[i].clear();
out[i]=in[i]=0;
}
for(i=0;i<eagenum;i++)
{
int u=sccno[eage[i].from];
int v=sccno[eage[i].to];
if(v!=u)
G[u].push_back(v),out[u]++,in[v]++;
}
}
int main()
{
int t,n,m,a,b,i;
while(~scanf("%d%d",&n,&m))
{
while(!s.empty())
s.pop();
eagenum=0;
memset(head,-1,sizeof(head));
while(m--)
{
scanf("%d%d",&a,&b);
add(a,b);
}
memset(dfn,0,sizeof(dfn));
memset(low,0,sizeof(low));
memset(sccno,0,sizeof(sccno));
memset(instack,0,sizeof(instack));
dfs_clock=scc_cnt=0;
for(i=1;i<=n;i++)
if(!dfn[i])
tarjan(i);
if(scc_cnt==1)
{
printf("0\n");
continue;
}
suodian();
a=b=0;
for(i=1;i<=scc_cnt;i++)
{
if(!out[i])
a++;
if(!in[i])
b++;
}
int ans=a>b?a:b;
printf("%d\n",ans);
}
return 0;
}