poj 1328 Radar Installation

                                                                                                                                            Radar Installation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 60327   Accepted: 13597

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
poj 1328 Radar Installation_第1张图片
Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
 
struct node
{
    double l,r;
} ls[1010];
 
bool cmp(node a,node b)
{
    return a.l < b.l;
}
int main()
{
    //freopen("in.txt","r",stdin);
    std::ios::sync_with_stdio(false);
    int n;
    double r;
    int t = 0;
    while(cin>>n>>r && (n || r))
    {
        bool flag = true;
        for(int i=0; i<n; i++)
        {
            double a,b;
            cin>>a>>b;
            if(fabs(b) > r)
                flag = false;
            else
            {
                ls[i].l = a - sqrt(r*r - b*b);
                ls[i].r = a + sqrt(r*r - b*b);
            }
        }
        cout<<"Case "<<++t<<": ";
        if(!flag)
            cout<<-1<<endl;
        else
        {
            int ant = 0;
            sort(ls,ls+n,cmp);
            node up = ls[0];
            for(int i=1; i<n; i++)
            {
                if(ls[i].l > up.r)
                {
                    up = ls[i];
                    ant++;
                }
                else if(ls[i].r < up.r)
                {
                    up = ls[i];
                }
            }
            cout<<ant+1<<endl;
        }
    }
    return 0;
}

 

你可能感兴趣的:(poj)