Highways
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 12118 |
|
Accepted: 3467 |
|
Special Judge |
Description
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.
Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.
The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.
Input
The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.
The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i
th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.
The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.
Output
Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.
If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.
Sample Input
9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2
Sample Output
1 6
3 7
4 9
5 7
8 3
Source
Northeastern Europe 1999
这道题好多人说用克鲁斯塔尔会TLE,其实优化一下代码是可以AC的。
我来说明一下:
①在距离计算方面,反正不用计算总距离,这里的sqrt函数就可以省略了,直接差的平方相加即可。
②可以先处理已经修好的路,然后后面进行路径生成的时候就可以用find函数略过一些路了,这样在用sort的时候会省一些时间。
③在鲁克斯塔尔生成树的时候,用一个变量记录已经修好的路,当它等于n-1的时候就可以停止运算了。
这样优化一下,时间上就没问题啦。
代码如下:
#include <cstdio>
#include <algorithm>
using namespace std;
int f[800];
struct node1
{
int st,end;
double cost;
}road[800*400];
struct node2
{
double x,y;
}data[800];
int find(int x)
{
if (x!=f[x])
f[x]=find(f[x]);
return f[x];
}
int join (int x,int y)
{
int fx,fy;
fx=find (x);
fy=find (y);
if (fx!=fy)
{
f[fx]=fy;
return 1;
}
return 0;
}
bool cmp1(node1 a,node1 b)
{
return a.cost<b.cost;
}
double dis(node2 a,node2 b)
{
return (a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y);
}
int main()
{
int n,m; //村庄数和已修好的路数
scanf ("%d",&n);
for (int i=1;i<=n;i++)
f[i]=i; //别忘了初始化
for (int i=1;i<=n;i++)
scanf ("%lf %lf",&data[i].x,&data[i].y);
scanf ("%d",&m);
while (m--)
{
int t1,t2;
scanf ("%d %d",&t1,&t2);
join(t1,t2);
}
int num=-1;
for (int i=1;i<n;i++)
{
for (int j=i+1;j<=n;j++)
{
if (find(i)!=find(j))
{
num++;
road[num].st=i;
road[num].end=j;
road[num].cost=dis(data[i],data[j]);
}
}
}
sort (road,road+num+1,cmp1);
int t=0;
for (int i=0;i<=num;i++)
{
if (join(road[i].st,road[i].end))
{
printf ("%d %d\n",road[i].st,road[i].end);
t++;
if (t==n-1)
break;
}
}
return 0;
}