【杭电oj】2602 - Bone Collector(01背包)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 46972    Accepted Submission(s): 19573


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
【杭电oj】2602 - Bone Collector(01背包)_第1张图片
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
   
   
   
   
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
   
   
   
   
14
 

Author
Teddy
 

Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contest


初学动态规划,这是01背包基础题,慢慢深入吧。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[1111];
struct node
{
	int v,w;
}c[1111];
int main()
{
	int u;
	int n,v;
	scanf ("%d",&u);
	while (u--)
	{
		scanf ("%d %d",&n,&v);
		memset (dp,0,sizeof (dp));
		for (int i = 1 ; i <= n ; i++)		//读题要注意,这俩别反了 
			scanf ("%d",&c[i].w);
		for (int i = 1 ; i <= n ; i++)
			scanf ("%d",&c[i].v);
		for (int i = 1 ; i <= n ; i++)
		{
			for (int j = v ; j >= c[i].v ; j--)
			{
				dp[j] = max (dp[j] , dp[j-c[i].v] + c[i].w);
			}
		}
		printf ("%d\n",dp[v]);
	}
	return 0;
}


你可能感兴趣的:(【杭电oj】2602 - Bone Collector(01背包))